Search RVMechanic.com
RV Ratings Go to Main Page RV mechanic on duty. Start at the home page.
RV Mechanic RV engine problems? RV mechanic help only a click away!

Hydro Flame Corp. 8531-II furnace not firing

Home > Discussion Forum > Mechanic's Corner (general)

Email Author email Ken Nelson  Reply to Message reply to message  Post New Message post new message      search forums
hidden layer
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Hydro Flame Corp. 8531-II furnace not firing Ken Nelson 2-1-10  
I have a Hydro Flame series 8531-II furnace in a '94 Jayco 5'th wheel. If batteries are fully charged it works fine. However,when the batteries become somewhat discharged the burner fails to ignite. The furnace still cycles and the blower blows cold air. Any ideas?
Re: Hydro Flame Corp. 8531-II furnace not firing RICK 2-1-10  
Furnace will not fire under 12.2 volts the blower motor does not spin fast enough to open the sail switch
Re: Looking for Hydro Flame burner head Part Number 2811 Gary Emmick 11-3-14  
Looking for Hydro Flame Burner Head Part Number 2811
Re: Hydro Flame Corp. 8531-II furnace not firing Ken Nelson 5-19-10  
The Hydro Flame 8531-II furnace will not ignite the burner unless the batteries are fully charged. It failed to ignite at 13+ volts. Could the sail switch that Rick mentioned in his post of 2-1-2010 be defective? If so could you tell me if the sail switch is on the circuit board, or where would I find it? A part number would be of great help if that is the problem. Thanks.
Re: Hydro Flame Corp. 8531-II furnace not firing tina 5-31-10  
What if you are running off 110 will it still not fire
Re: Hydro Flame Corp. 8531-II furnace not firing Kathy Shelock 10-8-12  
Furnace will not ignite on the 110. Sometimes it did then it quit completely.
Could you give us some feedback please. thank you
Re: Hydro Flame Corp. 8531-II furnace not firing jeff 3-7-15  
Cant seem to get igniter to work
Re: Hydro Flame Corp. 8531-II furnace not firing April 10-27-11  
We are having the exact same problem, whether we are on battery or plugged into electrical. Anyone out there have any tips hints assistance??
Thanks
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       





Useful Links
Recent RV mechanic and troubleshooting topics
  1990 Fleetwood Bounder / Ford 460 - No Engine/System Power
  1990 Fleetwood Bounder / Ford 460 - No Engine Electrical Power
  1987 Holiday Rambler wiring
  1978 triple e camper
  Rm2611 fridge problem
  Fuel Problem
  Country Coach sway bar bolt problem
  Chassis side a/c inop no power to compresor no ground.
  79 vandura 3500
  1973 Dodge Sportsman RV Instrument Panel
  Take over payment
  Wiring schematic for 1980 bigfoot travel trailer
  Control panel above driver not working at all
  1990 Skyline Nomad Weekender
  Cobra/Ford 1986 Owners Manual
  VIEW ALL

RV-Coach Online

Food Recipes & Blog

Homeschool Curriculum

Free Auto Insurance Quotes

Orange Beach/ Gulf Shores, AL Fishing




Print-friendly page
PRIVACY POLICY|TERMS & CONDITIONS| 1996 - 2015 RV-Coach Network - All Rights Reserved|Web Site by ITtelligent