RV, motorhome, and bus conversion mechanic's resource

RV and motorhome mechanic forum

Email Author email Larry Guggemos  Reply to Message reply to message  Post New Message post new message      search forums
hidden layer
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Duo -Therm 900 Series Gas - no heat! Larry Guggemos 10-6-06  
I have a Model 900 Series Duo-Therm Direct Vent Gas Furnace. It stopped putting out heat. After I turn the thermostst to on, the fan startes a few seconds later. The power comes on at the valve and then the power to the valve goes out after 6/7 seconds (ignition failure). The blower fan keeps running after ignition failure until 12/15 seconds after I turn off the thermostat (like it should). The unit uses the same valve and style ignition system as the Water Heater Unit does on this M/H.

Is there a fuse on the unit that may be blown? The schematic mentions a fuse. Do I need to remove the unit to do the needed service. I only ask this because I have trouble getting on my knees and am in the middle of the desert and it is getting cold. I have sucessfully done all the maintenence work on the W/H but am stumped with the Heater Unit??????

Re: Duo -Therm 900 Series Gas - no heat! Joe 10-6-06  
If there were a fuse, it would be for everything powered by 12 volts. It sounds like you have an ignition board problem. You would have to remove the unit to check for ignition. How have you determined it has no ignition?
Re: Duo -Therm 900 Series Gas - no heat! dickie 12-31-08  
What replace this furnace?
Re: Duo -Therm 900 Series Gas - no heat! dick 1-1-09  
I need a replacement furnace
Re: Duo -Therm 900 Series Gas - no heat! dick 1-1-09  
Replace ment
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Your Name:
Your Email:

Code is case-sensitive. Helps stop SPAM.

Advertiser Links